aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2020-04-25 04:43:17 +1200
committerTom Ryder <tom@sanctum.geek.nz>2020-04-25 04:43:17 +1200
commitc5c13fa16d7ab2a7577c676ec537e50ced813b7b (patch)
tree52de420f8edeaa9b86bacc1fe7811dc153333d8f /Makefile.PL
downloadnagios-check-ftp-c5c13fa16d7ab2a7577c676ec537e50ced813b7b.tar.gz
nagios-check-ftp-c5c13fa16d7ab2a7577c676ec537e50ced813b7b.zip
Version 1.00v1.00
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..ba195be
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,38 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'check_ftp',
+ AUTHOR => 'Tom Ryder <tom@sanctum.geek.nz>',
+ VERSION_FROM => 'libexec/check_ftp',
+ LICENSE => 'MIT',
+ INSTALLSCRIPT => '/usr/local/nagios/libexec',
+ INSTALLSITESCRIPT => '/usr/local/nagios/libexec',
+ EXE_FILES => ['libexec/check_ftp'],
+ MIN_PERL_VERSION => '5.010_001',
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => '0',
+ },
+ PREREQ_PM => {
+ 'English' => 0,
+ 'Exception::Class' => 0,
+ 'Monitoring::Plugin' => 0,
+ 'Path::Tiny' => 0,
+ 'Quota' => 0,
+ 'Try::Tiny' => 0,
+ },
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ homepage => 'https://sanctum.geek.nz/cgit/check_ftp.git/',
+ repository => {
+ type => 'git',
+ url => 'https://sanctum.geek.nz/code/check_ftp.git/',
+ web => 'https://sanctum.geek.nz/cgit/check_ftp.git/',
+ },
+ },
+ },
+ clean => { FILES => 'check_ftp-*' },
+);