aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorTom Ryder <tom@sanctum.geek.nz>2021-08-24 00:41:49 +1200
committerTom Ryder <tom@sanctum.geek.nz>2021-08-24 00:41:49 +1200
commit82266251bc460a8952ba2efbdb2c16cb50c12ebb (patch)
tree3e0e094bcbd16e402867dab399e8300253120422 /Makefile.PL
parentAdd README, bump VERSION (diff)
parentCorrect Perl version specification in Makefile.PL (diff)
downloadnagios-check-ftp-e38ccf9ca522e1c94ca845b4b223590defa6f7f7.tar.gz (sig)
nagios-check-ftp-e38ccf9ca522e1c94ca845b4b223590defa6f7f7.zip
Merge branch 'release/v2.00'HEADv2.00master
* release/v2.00: Relicense from MIT to GPLv3+ Correct Perl version specification in Makefile.PL Use specific exception name
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL22
1 files changed, 20 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ba195be..e97628a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,21 @@
+#
+# Copyright (C) 2020--2021 Tom Ryder <tom@sanctum.geek.nz>
+#
+# This file is part of nagios-check-ftp.
+#
+# nagios-check-ftp is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the Free
+# Software Foundation, either version 3 of the License, or (at your option) any
+# later version.
+#
+# nagios-check-ftp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
+# more details.
+#
+# You should have received a copy of the GNU General Public License along with
+# nagios-check-ftp. If not, see <https://www.gnu.org/licenses/>.
+#
use 5.006;
use strict;
use warnings;
@@ -7,11 +25,11 @@ WriteMakefile(
NAME => 'check_ftp',
AUTHOR => 'Tom Ryder <tom@sanctum.geek.nz>',
VERSION_FROM => 'libexec/check_ftp',
- LICENSE => 'MIT',
+ LICENSE => 'gpl_3', # or later
INSTALLSCRIPT => '/usr/local/nagios/libexec',
INSTALLSITESCRIPT => '/usr/local/nagios/libexec',
EXE_FILES => ['libexec/check_ftp'],
- MIN_PERL_VERSION => '5.010_001',
+ MIN_PERL_VERSION => '5.010001',
CONFIGURE_REQUIRES => {
'ExtUtils::MakeMaker' => '0',
},